TX-NR609 THX issue after firmware update

View previous topic View next topic Go down

TX-NR609 THX issue after firmware update

Post  gabe973 on Tue Jun 19, 2012 7:57 am

I updated the firmware in my Onkyo TX-NR609 yesterday, and after the update tried to watch a blu ray. It started out playing fine when there was a two channel source, but as soon as it switched to Dolby Digital 5.1 the receiver switched over to a THX mode and an extremely loud crackling/popping/clicking/static sound started coming out of the speakers. So loud I thought the speakers would blow. I turned the volume all the way down to -infinity, and the sounds could still be heard. Muting finally got rid of the noise. I changed over from THX to Dolby Digital EX, and everything played fine.

I tried other sources (DirecTV) and the same thing happened. Whenever changing to a THX mode, extremely loud garbled sound starts coming out of the speakers. Changing to anything other than a THX mode fixes this.

I have not tried a factory reset yet. Is there a way to force a firmware update, so that it will try to update the firmware again even though it has the latest? Anyway to move backwards in firmware?

Thanks...

Gabe

gabe973

Posts : 3
Join date : 2012-06-19

View user profile

Back to top Go down

Re: TX-NR609 THX issue after firmware update

Post  coxie2 on Tue Jun 19, 2012 9:26 pm

Gabe You might try and disconnect the power for a minute or so and then power up the unit. I believe that after a master reset, the firmware upgrade you downloaded will still be there. Not sure. I do not believe there is a way to return to the previous firmware. Did you do a net upgrade or download to a flash drive ? Keep us posted.

coxie2

Posts : 26
Join date : 2012-03-05
Age : 57
Location : Illinois USA

View user profile

Back to top Go down

Re: TX-NR609 THX issue after firmware update

Post  Ametrica on Tue Jun 19, 2012 10:12 pm

What firmware version did you install?

Ametrica

Posts : 16
Join date : 2011-11-24
Location : Ohio

View user profile

Back to top Go down

Re: TX-NR609 THX issue after firmware update

Post  gabe973 on Wed Jun 20, 2012 8:57 pm

Thanks for the replies.

The firmware is 1131-1400-0010-8106 and I updated over NET. It finished with a COMPLETED and it appeared like the update took fine.

I've just tried the following...

-Unplugging and plugging back in - goes through self test with no indication of problems. Noise still there.
-Tried updating the same firmware over USB. Wouldn't let me. Said that I was already up to date.
-Did a CLEAR. Noise still there.
-Unplugged and plugged back in (after CLEAR). Noise still there.
-Tried updating the same firmware over USB again (after CLEAR). Wouldn't let me.

Not sure what else to try. Other than wait for a new firmware to be released and see if that works. Or try to get it repaired.

I don't even use THX modes, so it doesn't really effect me...unless one of the kids pushes a wrong button and freaks out when it starts making that noise.

Gabe

gabe973

Posts : 3
Join date : 2012-06-19

View user profile

Back to top Go down

Re: TX-NR609 THX issue after firmware update

Post  OnkyoUSA on Thu Jun 21, 2012 4:33 pm

Hi gabe973,

I do not think it has anything to do with the firmware or your setup at this point. I would suggest a service center look into this further for you.
avatar
OnkyoUSA
Admin

Posts : 4077
Join date : 2011-10-06
Location : New Jersey

View user profile http://onkyoproductsupport.forumotion.com

Back to top Go down

Same Issue

Post  kmccullough364 on Mon Jul 30, 2012 11:27 am

I have had the same exact issue. Updated firmware via USB on 7-28-12. Tried the exact same troubleshooting measures as gabe973 but with no luck. Only having issues in THX mode. Very odd that the issue only occured after update. So not sure about the "not the firmware take it to a service center" response. Especially since i have only had the receiver hooked up and operating for ONE FULL DAY. The question posted by gabe973 about the firmware being reverted back to the previous version was not answered. If I have to take it to a service center, am i going to have to pay for the service? Has anyone else had this issue?

kmccullough364

Posts : 3
Join date : 2012-07-30

View user profile

Back to top Go down

Re: TX-NR609 THX issue after firmware update

Post  OnkyoUSA on Mon Jul 30, 2012 2:29 pm

Hi kmccullough364,

In answer to his reply the firmware can not be reverted back by the end users and may be able to by a service center. If you are still under the warranty the you must abide by that.

Thank you,

Forum Moderator.
avatar
OnkyoUSA
Admin

Posts : 4077
Join date : 2011-10-06
Location : New Jersey

View user profile http://onkyoproductsupport.forumotion.com

Back to top Go down

Re: TX-NR609 THX issue after firmware update

Post  kmccullough364 on Mon Jul 30, 2012 2:35 pm

What is causing this to occur? Has Onkyo figured this out yet? If the service center can find no obvious fault, one would have to assume a firmware glitch. If this is the case, will i have to pay the service fee? Thank you.

kmccullough364

Posts : 3
Join date : 2012-07-30

View user profile

Back to top Go down

Re: TX-NR609 THX issue after firmware update

Post  OnkyoUSA on Mon Jul 30, 2012 2:58 pm

Hi kmccullough364,

I will bring this to the proper department. In the mean time you are responsible for getting it to the service center if you are still under the warranty and we will are responsible for getting it back to you.

Thank you,

Forum Moderator.
avatar
OnkyoUSA
Admin

Posts : 4077
Join date : 2011-10-06
Location : New Jersey

View user profile http://onkyoproductsupport.forumotion.com

Back to top Go down

Re: TX-NR609 THX issue after firmware update

Post  Ametrica on Sun Aug 05, 2012 11:10 pm

gabe973 wrote:Thanks for the replies.

The firmware is 1131-1400-0010-8106 and I updated over NET. It finished with a COMPLETED and it appeared like the update took fine.

I've just tried the following...

-Unplugging and plugging back in - goes through self test with no indication of problems. Noise still there.
-Tried updating the same firmware over USB. Wouldn't let me. Said that I was already up to date.
-Did a CLEAR. Noise still there.
-Unplugged and plugged back in (after CLEAR). Noise still there.
-Tried updating the same firmware over USB again (after CLEAR). Wouldn't let me.

Not sure what else to try. Other than wait for a new firmware to be released and see if that works. Or try to get it repaired.

I don't even use THX modes, so it doesn't really effect me...unless one of the kids pushes a wrong button and freaks out when it starts making that noise.

Gabe

Gabe,

I have the same version of Firmware, the most up-to-date. I also have a Vizio VBR120A Blu-Ray player from Wal-Mart. I recently bought 3 Blu-ray disks and played the first one, Van Helsing. I went through all of the audio modes, starting from Direct, including all the THX modes, and not one failed or functioned incorrectly. There was no noise in any of the modes.

Your firmware must have been corrupt and did not install correctly. It is a shame that the unit does not allow you to download again and repair the installation. You should be able to obtain the previous version, reinstall it, check to see if everything works fine, then re-download the latest version and attempt another update. Taking the unit to a repair shop should not be an option.


Ametrica

Posts : 16
Join date : 2011-11-24
Location : Ohio

View user profile

Back to top Go down

Re: TX-NR609 THX issue after firmware update

Post  gabe973 on Mon Aug 06, 2012 9:26 am

I've been meaning to post back with an update. I brought the receiver in for service (ABL Electronics) and received it back. The notes said that it was a bad HDMI board. Not sure how a bad HDMI board would effect only the THX modes, but that's what they said they replaced and everything is back to working again.

I was able to find another person with the same issue on another forum, it ended up at the same service center, and they replaced the HDMI board on his as well.

http://forums.audioholics.com/forums/amps-pre-pros-receivers/79548-onkyo-tx-nr609-firmware-problem-2.html

Gabe


gabe973

Posts : 3
Join date : 2012-06-19

View user profile

Back to top Go down

Thanks

Post  kmccullough364 on Tue Oct 23, 2012 10:36 pm

Thanks for the update Gabe. I sent mine back to Onkyo via Fry's Electronics. That was back on the 30th of July!! It's insane that it is taking this long. The only good side of this is they supplied me with a loaner so I'm not dead in the water. Here's hoping someone looks at this, replaces my HDMI board like yours and drives on.

kmccullough364

Posts : 3
Join date : 2012-07-30

View user profile

Back to top Go down

Re: TX-NR609 THX issue after firmware update

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum