HT-RC360 - No sound, no picture, was working for 10 months with no problems.

View previous topic View next topic Go down

HT-RC360 - No sound, no picture, was working for 10 months with no problems.

Post  Mistere311 on Fri Aug 17, 2012 8:38 pm

Wondering if anyone has a thought: HT-RC360 - No sound, no picture, was working for 10 months with no problems. I've tried the factory reset - nothing same problem. With only the speakers and FM antenna installed, I get no sound and no picture over the HDMI. I know there is nothing wrong with the cable or TV and everything was working 100% for 10 months, I turn it on today and this problem. Tried to USB firmware after the factory reset, has been stuck on the "now initializing" message for 2 hours. Do I have a defective unit? Please advise.

Mistere311

Posts : 4
Join date : 2012-08-17

View user profile

Back to top Go down

30 mins?

Post  Mistere311 on Mon Aug 20, 2012 1:39 pm

Well, I tried to call the 800 number over the weekend for help; waited 35 mins with no answer. Bummer, I guess I will try again tonight.

Mistere311

Posts : 4
Join date : 2012-08-17

View user profile

Back to top Go down

Re: HT-RC360 - No sound, no picture, was working for 10 months with no problems.

Post  OnkyoUSA on Mon Aug 20, 2012 6:16 pm

Please reply to the following email (onkyoadmin@us.onkyo.com) with the following information:

Name:
Email:
Serial Number:
Dealer of Purchase:
Date of Purchase:
City/ State:
Contact Number:

We will further assist you if you are not able to contact a Product Support; or we will have someone contact YOU back to further troubleshoot/ resolve your issue.

Thank You;

Forum Moderator
avatar
OnkyoUSA
Admin

Posts : 4077
Join date : 2011-10-06
Location : New Jersey

View user profile http://onkyoproductsupport.forumotion.com

Back to top Go down

UPDATE

Post  Mistere311 on Wed Sep 19, 2012 11:38 am

Updating my problem here:

On 8.22.12 my authorized service shop ordered an HDMI board for my unit, which appears to be a KNOWN PROBLEM with these receivers. See the "HDMI OUT" complaints all over this forum, amazon, and other sites CLICK HERE FOR AMAZON REVIEWS

On 9.19.12, I was informed this part is on back order and "might" be release 10.22.12. I might get my receiver back before the end of the year. That is simply unacceptable for a product less than a year old, I mean over two months in the shop? Really Onkyo?


Mistere311

Posts : 4
Join date : 2012-08-17

View user profile

Back to top Go down

Re: HT-RC360 - No sound, no picture, was working for 10 months with no problems.

Post  OnkyoUSA on Wed Sep 19, 2012 12:34 pm

Thank you for your email; I will be looking further into this and advise you shortly.

Cordially;

Forum Moderator
avatar
OnkyoUSA
Admin

Posts : 4077
Join date : 2011-10-06
Location : New Jersey

View user profile http://onkyoproductsupport.forumotion.com

Back to top Go down

Re: HT-RC360 - No sound, no picture, was working for 10 months with no problems.

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum